const regex = /_(?!(?<=(?<!\d)\d{8}_)\d{6}(?!\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_(?!(?<=(?<!\\d)\\d{8}_)\\d{6}(?!\\d))', 'gm')
const str = `Patate_17890505_TitreEnCamelCase.ext
EPFL_AlgebreLineaire
TaxonomieProprietesFonctionsComplexes.v0.ipe.20210302_005606.pdf
1_
12_
_1
_12
12345678_
_123456
12345678_12345
1234567_123456
1234567_12345
123456_12345
12345678_1234567
123456789_123456
123456789_1234567
_patate__truc__
___
foo_12345678
foo_12345678_123456_bar
12345678_123456
foo12345678_123456bar`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);