const regex = /(?<=^.*\bLocation:[^(]*\()[^)]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^.*\\bLocation:[^(]*\\()[^)]+', 'g')
const str = `Location: https://crm.truboprovod.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)
Location: https://crm.truboprovod.ru/CRM/api/data/v10.0/gm_preorders(a689ef1d-2a6f-eb11-a10b-ac4f6b465e3b)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}