re = /(?<=^(?:(?!\bLocation:)[\s\S])*?\bLocation:[^(]*\()[^)]+/
str = '--batchresponse_bla_bla_bla_
--changesetresponse__bla_bla_bla_
--
Location: https://site.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)
OData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)
_bla_bla_bla_
--changesetresponse__bla_bla_bla_Location: https://site.ru/CRM/api/data/v9.0/gm_preorders(a841eb4e-2fdf-eb11-a30b-ac1f6b465e3b)
OData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(a841eb4e-2fdf-eb11-a30b-ac1f6b465e3b)
_bla_bla_bla_
--changesetresponse_n_bla_bla_bla_
Location: https://site.ru/CRM/api/data/v9.0/gm_preorders(74748d08-2ee6-eb11-a30b-ac1f6b465e3b)
OData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(74748d08-2ee6-eb11-a30b-ac1f6b465e3b)
n_bla_bla_bla_
--changesetresponse_etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end