$re = '/^-{1,2}[^-]+/';
$str = '--split 2 --random';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);