$re = '/^([-+]?\d{1,3}(?: \d{3})*(?:,[0-9]+)?)$/m';
$str = '6 000,00
12 345 678,9
123 456
1,2
321 321 321,321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);