// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href=("[^"]+"|'[^']+')"#).unwrap();
let string = "<a href=\"http://github.com/den2736\">
<a href=\"https://github.com/den2736\">
<a href=\"#ancor\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}