re = /^(?!.*")(.*)$|^[^"]*"(.*?)".*$/m
str = 'fsdsdf "This one" fdsfsd ghjhgj "sfdsf"
Just This '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end