import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<(p|h3.*)>.*<\\/(.*)>)|(<(ul.*)>[\\s\\S]*<\\/(ul)>))";
final String string = "<h1>This is heading 1</h1>\n"
+ "<h2 style=\"color: aqua\">This is heading 2</h2>\n"
+ "<h3>This is heading 3</h3>\n"
+ "<p>This is a paragraph.</p>\n"
+ "<p>This is another paragraph.</p>\n"
+ "<a href=\"https://www.w3schools.com\">This is a link</a>\n"
+ "<ul>\n"
+ " <li>Coffee</li>\n"
+ " <li>Tea</li>\n"
+ " <li>Milk</li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}