package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\S+[,.?!]?\s+){1,200}[\s\S]*?(\. |!|\?)`)
var str = `Therapy extract straw and chitosan from shrimp shells alone accounted for 2, 4, 6, 8 and 10% found that the extract straw 8% is highly effective in inhibiting the growth of algae Microcystis spp. The number of cells and the amount of chlorophyll a was reduced during treatment. Both value decreased continuous until the end of the trial. On the last day of the experiment, the cell number decreased to 64.21% and the amount of chlorophyll a decreased of 37.39% compared with the control. The extract straw 2, 4, 6 and 10% cells Microcystis spp. was 1182, 4281, 4089 and 18.53% respectively. The amount of chlorophyll a decreased of 1370, 1765, 2802 and 22.66% respectively. (Figure 1-2) If the chitosan from shrimp shells in a proportion of 10% to get rid of cell toxic algae Microcystis spp. was the highest at 79.69% inhibition of chlorophyll a decreased to 47.85% compared to the control in 44 day. The chitosan from shrimp shells 2, 4, 6 and 8% efficiency into the cell numbers decreased 6435, 6176, 7043 and 77.16% respectively and chlorophyll a decreased 1195, 4101, 1861 and. 42.78% respectively. (Figure 3-4) In addition, treatment with the extract of rice straw mixed with chitosan from shrimp shells in the ratio of 3:1, 2:1, 1:1, 1:2 and 1:3 each treatment decreased significantly. continuing from 3 to 44 days of trial. Therapy extract straw and chitosan from shrimp shells alone accounted for 2, 4, 6, 8 and 10% found that the extract straw 8% is highly effective in inhibiting the growth of algae Microcystis spp. The number of cells and the amount of chlorophyll a was reduced during treatment. Both value decreased continuous until the end of the trial. On the last day of the experiment, the cell number decreased to 64.21% and the amount of chlorophyll a decreased of 37.39% compared with the control. The extract straw 2, 4, 6 and 10% cells Microcystis spp. was 1182, 4281, 4089 and 18.53% respectively. The amount of chlorophyll a decreased of 1370, 1765, 2802 and 22.66% respectively. (Figure 1-2) If the chitosan from shrimp shells in a proportion of 10% to get rid of cell toxic algae Microcystis spp. was the highest at 79.69% inhibition of chlorophyll a decreased to 47.85% compared to the control in 44 day. The chitosan from shrimp shells 2, 4, 6 and 8% efficiency into the cell numbers decreased 6435, 6176, 7043 and 77.16% respectively and chlorophyll a decreased 1195, 4101, 1861 and. 42.78% respectively. (Figure 3-4) In addition, treatment with the extract of rice straw mixed with chitosan from shrimp shells in the ratio of 3:1, 2:1, 1:1, 1:2 and 1:3 each treatment decreased significantly. continuing from 3 to 44 days of trial. Therapy extract straw and chitosan from shrimp shells alone accounted for 2, 4, 6, 8 and 10% found that the extract straw 8% is highly effective in inhibiting the growth of algae Microcystis spp. The number of cells and the amount of chlorophyll a was reduced during treatment. Both value decreased continuous until the end of the trial. On the last day of the experiment, the cell number decreased to 64.21% and the amount of chlorophyll a decreased of 37.39% compared with the control. The extract straw 2, 4, 6 and 10% cells Microcystis spp. was 1182, 4281, 4089 and 18.53% respectively. The amount of chlorophyll a decreased of 1370, 1765, 2802 and 22.66% respectively. (Figure 1-2) If the chitosan from shrimp shells in a proportion of 10% to get rid of cell toxic algae Microcystis spp. was the highest at 79.69% inhibition of chlorophyll a decreased to 47.85% compared to the control in 44 day. The chitosan from shrimp shells 2, 4, 6 and 8% efficiency into the cell numbers decreased 6435, 6176, 7043 and 77.16% respectively and chlorophyll a decreased 1195, 4101, 1861 and. 42.78% respectively. (Figure 3-4) In addition, treatment with the extract of rice straw mixed with chitosan from shrimp shells in the ratio of 3:1, 2:1, 1:1, 1:2 and 1:3 each treatment decreased significantly. continuing from 3 to 44 days of trial. The best extract of rice straw on chitosan from shrimp shells of the laboratory effective deterrent Microcystis spp. was mixed with Microcystis spp. from natural sources in a final volume of 500 L in 1 m cement diameter. The experiment was repeated 3 time. The controllers were not added straw extract and chitosan from shrimp shells. It were filled a Microcystis spp. from natural sources only. The best extract of rice straw on chitosan from shrimp shells of the laboratory effective deterrent Microcystis spp. was mixed with Microcystis spp. from natural sources in a final volume of 500 L in 1 m cement diameter. The experiment was repeated 3 time. The controllers were not added straw extract and chitosan from shrimp shells. It were filled a Microcystis spp. from natural sources only. The best extract of rice straw on chitosan from shrimp shells of the laboratory effective deterrent Microcystis spp. was mixed with Microcystis spp. from natural sources in a final volume of 500 L in 1 m cement diameter. The experiment was repeated 3 time. The controllers were not added straw extract and chitosan from shrimp shells. It were filled a Microcystis spp. from natural sources only."`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}