$re = '/(\d+)[_](\d+)/mu';
$str = '"id": "101_2345"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);