$re = '/^0*\K.+/m';
$str = 'ABC0123
0ABC0123
000ABC0123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);