$re = '/^(19[0-9]{2}|20[0-9]{2})$/m';
$str = '2024
1900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);