$re = '/(\p{L}).*\1/m';
$str = 'asdf
fdas
asds
d fm
dfaa
aaaa
aabb
aaabb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);