package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:X\.{10}\n)(\.))|((?:\.X\.{9}\n)(:?\.)(\.))|((?:\.{2}X\.{8}\n)(:?\.{2})(\.))`)
var str = `X..........
...........
.X.........
...........
..X........
...........`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}