using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\s+-\s+.*?(?=\s*(?:,\s*)?\d+\s+-\s|\Z)";
string input = @"123 - Footwear, 5678 - Apparel, Accessories & Luxury Goods, 9876 - Leisure Products
321 - Apparel & Accessories, 4321 - Apparel & Accessories > Handbags, Wallets & Cases, 187 - Apparel & Accessories > Shoes";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}