$re = '/Licht_WZ:o[nf]+|Licht_Kueche:o[nf]+/m';
$str = 'Licht_WZ:on
Licht_WZ:off
Licht_Kueche:on
Licht_Kueche:off
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);