$re = '/[0-9]{17}/m';
$str = '12345678901234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);