#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?sm)^\d\d?[.] {3,7}(.*?)(?=\n\n\d\d?\. |\Z)"
Local $sString = "INTERNATIONAL MONETARY FUND 7" & @CRLF & _
"BELGIUM" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"POLICY DISCUSSIONS—MAINTAINING THE REFORM" & @CRLF & _
"MOMENTUM" & @CRLF & _
"7. The current recovery is an opportunity to strengthen the resilience and growth" & @CRLF & _
"potential of the Belgian economy. The government's ability to deal with future shocks will depend" & @CRLF & _
"on whether it implements the right policies now while the economy continues to recover." & @CRLF & _
"" & @CRLF & _
" First, with public debt above 100 percent of GDP and only starting to come down, Belgium still" & @CRLF & _
" has a long way to go to rebuild buffers and achieve a more sustainable fiscal position. This will" & @CRLF & _
" require following through on plans to gradually move toward structural balance." & @CRLF & _
"" & @CRLF & _
" Second, with real GDP growth projected at only around 1½ percent for the foreseeable future," & @CRLF & _
" further labor and product market reforms are needed to increase productivity growth, raise" & @CRLF & _
" potential output, and integrate vulnerable groups into the labor market." & @CRLF & _
"" & @CRLF & _
" Third, although the financial sector has recovered since the crisis and is generally sound, cyclical" & @CRLF & _
" vulnerabilities are rising and new challenges are emerging, suggesting the need for vigilance" & @CRLF & _
" and proactive policies.3" & @CRLF & _
"" & @CRLF & _
"8. The government agreed last summer on a new package of measures related to" & @CRLF & _
"taxation, the labor market, and social benefits (Table 2 and Box 1). The most notable reform was" & @CRLF & _
"a reduction in Belgium's corporate income tax (CIT) rate from 34 percent to 25 percent, to be" & @CRLF & _
"phased in over the next three years (SMEs will benefit from a reduced rate of 20 percent starting in" & @CRLF & _
"2018). To compensate for the resulting revenue loss, the notional interest rate deduction (NID) was" & @CRLF & _
"modified to apply only to incremental corporate equity rather than to the total stock, and new anti-" & @CRLF & _
"tax avoidance measures were introduced consistent with Belgium's EU obligations.4 Together, the" & @CRLF & _
"measures are designed to enhance Belgium's competitiveness while preserving revenue neutrality." & @CRLF & _
"" & @CRLF & _
"9. Policy discussions focused on the importance of maintaining the reform momentum" & @CRLF & _
"and not yielding to complacency. Achieving the balanced budget goal will require efforts at all" & @CRLF & _
"levels of government to make spending more efficient and safeguard revenues (Section A)." & @CRLF & _
"A combination of policies and reforms could help raise productivity growth, including increasing" & @CRLF & _
"investment in infrastructure and enhancing competition in services (Section B). To fully realize" & @CRLF & _
"Belgium's employment potential, it will be critical to address the severe fragmentation of the labor" & @CRLF & _
"market (Section C). To preserve financial stability, the authorities should address vulnerabilities in the" & @CRLF & _
"mortgage market and carefully navigate the transition toward a European Banking Union (Section D)." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
" A comprehensive assessment of Belgium's financial sector took place in 2017 under the Financial Sector" & @CRLF & _
"Assessment Program (FSAP)." & @CRLF & _
"4" & @CRLF & _
" The NID aims to neutralize the CIT treatment of debt and equity by supplementing the deductibility of interest with" & @CRLF & _
"a deduction that is the product of corporate equity and a notional interest rate." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")