re = /^<img((?!alt=".*")(\n|.))*(>|\/>)$/m
str = '<img >
<img src="jasfslkj" alt="kaas">
<img koffie="zwart"
/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end