$re = '/(?:(((http|https|ftp|ftps)\:\/\/)|(www\.))[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\:[0-9]+)?(\/\S*)?)(?<!\.jpg|\.png|\.gif|\.jpeg)(?:\s|$)/m';
$str = 'http://example.com/test
http://example.com/test.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);