re = /class="?Mso|style=["'][^< ]*\bmso-/mi
str = '<b style=\'mso-bidi-font-weight:normal\'><span
style=\'font-size:11.0pt;line-height:107%;font-family:"Calibri",sans-serif;
mso-ascii-theme-font:minor-latin;mso-fareast-font-family:Calibri;mso-fareast-theme-font:
minor-latin;mso-hansi-theme-font:minor-latin;mso-bidi-font-family:"Times New Roman";
mso-bidi-theme-font:minor-bidi;mso-ansi-language:EN-US;mso-fareast-language:
EN-US;mso-bidi-language:AR-SA\'>Update translations after adding </span></b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end