$re = '/(?<=#)(?:[1-9]\d+|[2-9])/m';
$str = 'randomstring#11#1#0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);