$re = '/([^\W_]+)_([^\W_]+)\.\w+/m';
$str = 'image_one.jpg
image_two.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);