$re = '/AUTH\s+CANCELLED\s+(.*?)\s+\d{16}XXXXXXXX/i';
$str = 'CXXXXX1XXXXX000000000000000XXXXXXXXXXXXXX PAYMENTS XXXX ELECTRONIC XXXXXXXX AUTH CANCELLED 20250508000000000000001800008XXXXXXXX 20250508ABCXXXXXXXXX 2025050913043600XXXXXXXX BXX XXX
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);