re = /(012|123|234|345|456|567|678|789|890|901|abc|bcd|cde|def|efg|fgh|ghi|hij|ijk|jkl|klm|lmn|mno|nop|opq|pqr|qrs|rst|stu|tuv|uvw|vwx|wxy|xyz|yza|zab|ABC|BCD|CDE|DEF|EFG|FGH|GHI|HIJ|IJK|JKL|KLM|LMN|MNO|NOP|OPQ|PQR|QRS|RST|STU|TUV|UVW|VWX|WXY|XYZ|YZA|ZAB)/
str = 'helloworld
hellloworld
aaabc
abcddd
bbabba
castle123
javaxyz
456ythonjkl
aaBcddrf
aABCdzab
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end