// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"workspaces\/(?<workspace_name>[^\/]+)\/runs\/run-(?<workspace_id>[^\"]+)"#).unwrap();
  let string = "10.218.136.20 - - [30/Jun/2023:02:36:32 +0000] \"GET /api/v2/runs/run-g1mhsXooK6aKV9bS?include=plan%2Ccost_estimate%2Capply%2Ccreated_by HTTP/1.1\" 200 5460 \"https://terraform.srv.companyname.com.au/app/customer/workspaces/a00ccc-tfe-test02-customer_infra_ping/runs/run-g1mhsXooK6aKV9bS\" \"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36\"";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}