re = /(\[code=[^\]]*])([^]*?)(\[\/code])/i
str = '[code=any]some code inside of here[/code]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end