$re = '/\b\w*?(?:ha\w*a|a\w*ha).*?\b/m';
$str = 'aha foo harpa bar hala haa abha bhab babh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);