$re = '~\[url
(?|
] ((https?://[^[]+))
|
(?:="(https?://[^"]+)")] (.+?)
)
\[/url]~ix';
$str = '[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]';
$subst = "<a href=\"$1\">$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;