$re = '/^\/{3}.*(?:\r?\n\/{3}.*)*/m';
$str = '# this is block1
/// text
/// text
/// text
/// text
# this is block2
/// text
/// text
/// text
/// text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);