$re = '/^(?!red|green|blue)([a-z0-9]+)$/i';
$str = 'red green blue purple';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);