$re = '/(?<=~).*(?=\n\n~PA)/m';
$str = '~AA40% -~13,683.89
~FINALDATA
~PA RT#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);