using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"gr(a{2,}|[ieu])y";
string input = @"
gray, grey, grup, graaay";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}