#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\s*\.\s*([\w\W]*?)(?=[aA]\))"
Local $sString = "8. X-XIII asrlarda barpo etilgan inshootlar to‘g‘ri berilgan qatorni aniqlang." & @CRLF & _
"1) Ismoil Somoniy maqbarasi, 2) Masjidi Kalon," & @CRLF & _
"3) Namozgoh, 4) Minorayi Kalon, 5) Vobkent minorasi, 6) Ahmad Yassaviy maqbarasi, 7) Jarqo‘rg‘on minorasi, 8) Kaltaminor." & @CRLF & _
"A) 1, 2, 3, 6, 7" & @CRLF & _
"B) 1, 3, 4, 5, 7" & @CRLF & _
"C) 1, 2, 4, 6, 8" & @CRLF & _
"D) 2, 3, 4, 6, 7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")