$re = '/(?\'a\'~)(?=(?!\s)(?:(?!\k\'a\').)+(?<!\s)\k\'a\')|(?=(?=(?\'b\'[\s\S]*))(?\'c\'\k\'a\'(?!\s)(?:(?!\k\'a\').)+(?<!\s)(?=\k\'b\'\z)|(?<=(?=x^|(?&c))[\s\S])))\k\'a\'/';
$str = '~test~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);