$re = '/^-?\d+\.*\d*;\s*-?\d+\.*\d*/i';
$str = '52.686; -2.193';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);