$re = '/\b(MLS(?:®|®?(?: Number)?)[^A-Za-z0-9]*)([^?*\/\\\\:;<> ]{1,23}\d{2,23}[^?*\/\\\\:;<> ]{1,23})/mi';
$str = 'accusantique et o (MLS® R2608327). Sed ut perspiciatis voluptatem mls listing :MLS®#:12243235435 beatae vitae dicta MLS Number#:12243235435 sunt 3543654654675645654654 explicabo .
dfnjkgfkhgb mls:#234234245 fgjhfgf 3498234789 dshfdsfgbjhsf.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);