package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.\.csv|\.xml$`)
var str = `ña.csvskdjñalsd.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}