package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Z]?(\d)?).{8,}$`)
var str = `ddfdsfsdfsfsf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}