import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([AC-FHKNPRTV-Y]\\d{2}|D6W)\\s[0-9AC-FHKNPRTV-Y]{4}$";
final String string = "D6W 1234\n"
+ "A23 0984\n"
+ "D00 AV92\n"
+ "Y63 1FHK\n"
+ "A00 0000\n"
+ "D44 N4X4\n"
+ "A65 F4E2\n"
+ "D6W FNT4\n"
+ "T37 F8HK\n"
+ "D14 N2Fz\n"
+ "a65 f4e2\n"
+ "D6W FNTO";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}