package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
[^ (]+
| (?>
\(
[^()]*
\)
)
| \(
)+
(?= [ ] | $ )
`)
var str = `hello (split this) string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}