$re = '/[-a-zA-Z:]+/m';
$str = 'data-test
data-test_test
1test
test2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);