$re = '/^0*[1-9]\d*(?:,0*[1-9]\d*)*$/';
$str = '34,0,354';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);