const regex = /^[0-9]{4}\-(?:0[1-9]|1[0-2])\-(?:0[1-9]|[1-2][0-9]|3[0-1])\s+(?:2[0-3]|[0-1][0-9]):[0-5][0-9]:[0-5][0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{4}\\-(?:0[1-9]|1[0-2])\\-(?:0[1-9]|[1-2][0-9]|3[0-1])\\s+(?:2[0-3]|[0-1][0-9]):[0-5][0-9]:[0-5][0-9]$', 'gm')
const str = `2015-12-21 14:44:43
2015-12-31 00:44:43
2015-01-32 00:44:43
2015-01-30 20:44:43
2015-01-30 24:44:43
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}