package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<WebAddress> (?&Protocol){0,}(?&Host)(?:\:(?&Port)){0,1}(?&Path){0,1})(?=\s|$)
(?<Protocol> \w{2,}\:\/\/)
(?<Host> (?&NameParts)(?&Suffix))
(?<NameParts> (\w{2,}\.){1,})
(?<Suffix> (\w{2,}))
(?<Port> (\d{1,5}))
(?<Path> (\/\S{1,}))
)
((?&WebAddress))`)
var str = `http://asdf.com
http://www.google.com:80/path?asdf-asdf=adsfddk@ffs
http://asdf.com
https://adfdfffdfds.edu
asd.edu:8383
jjhgf.net:21
https://uno.mbsc.asdf.com:1233
google.com
mbsc.unomaha.edu
ftp.unomaha.edu
asdf.com
ftp.dd.dfffffdfdfdfdfdfdfdfdfdfdf
sdf.com
abc.def.com
https://msn.sdf.com:123
http://asd.com
ftp://ftp.mbsc.unomaha.edu:81813
http://www.mbsc.unomaha.edu
https://www.mbsc.unomaha.edu:1231/path?docid=-123
weather.tv
www.google.com
google.com/asdf?coxd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}