$re = '/(\/?[^\/\.\n]+?\/(?P<DOUBLE>\.\.\/))/mi';
$str = 'Find all cases of /folder/../ and replace them with /
/path/./path
/path/path../
/path./path/
path/../path/
../path/
../../path/path
abcedf/earg/../aerg/acde/path/../../../../path../../
path/../
/path/../
/path/../../
/path/../../../../abc/../
/../
/../../
/../../abc/
../../abc/../abc/
//../../';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;