$re = '/(?<=\{).*?(?=\})/';
$str = '{123} {12.3.2015 moday} {THIS IS A TEST}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);