$re = '/^\w+/m';
$str = '271546
271546-1
271546-4
a123
a123-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);