#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xi)(?:" & @CRLF & _
" <\?php" & @CRLF & _
" (?:" & @CRLF & _
" [^"'\/<\?]+" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" "(?:[^\\"]|\\[\s\S])*"" & @CRLF & _
" |" & @CRLF & _
" # '(?:[^\\']|\\[\s\S])*'" & @CRLF & _
" #|" & @CRLF & _
" \/\*(?:[^\*]|\*[^\/])*\*\/ " & @CRLF & _
" |" & @CRLF & _
" (?:\#|\/\/).+(?:\n|$)" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" <<<\s*" & @CRLF & _
" (?:" & @CRLF & _
" (?:'([a-zA-Z0-9_]+)'\s*?\n)(?:[^\n]*\n)*?\s*\1\s*?;?\s*?(?:\n|$)" & @CRLF & _
" |" & @CRLF & _
" (?:([a-zA-Z0-9_]+)\s*?\n)(?:[^\n]*\n)*?\s*\2\s*?;?\s*?(?:\n|$)" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?:[^?]|\?[^>])" & @CRLF & _
" )*" & @CRLF & _
" (?:\?>|$)" & @CRLF & _
")"
Local $sString = "<!--" & @CRLF & _
" The PHP masterpage" & @CRLF & _
"-->" & @CRLF & _
"<?php" & @CRLF & _
"$matches = array();" & @CRLF & _
"// separates " & @CRLF & _
"$re = <<<PREG" & @CRLF & _
" /^" & @CRLF & _
" " & @CRLF & _
" (?:\\s*(?:<!--.*?-->))*" & @CRLF & _
" <\\?php\\s*include\\s*(\\()?\\s*([\\'\\"])(?:(?!\\2).)*(?-i)Master\\.php(?i)\\2(?(-2)\\))\\s*;\\s*\\?>\\s*" & @CRLF & _
" (?:\\s*(?:<!--.*?-->))*" & @CRLF & _
" <master\\s*src=([\\'\\\"])(?<master_url>.+?)\\3\\/>(?<content>[\s\S]*)" & @CRLF & _
" $" & @CRLF & _
" /ix" & @CRLF & _
"PREG;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$re = <<<PREG2" & @CRLF & _
" /^" & @CRLF & _
" " & @CRLF & _
" (?:\\s*(?:<!--.*?-->))*" & @CRLF & _
" <\\?php\\s*include\\s*(\\()?\\s*([\\'\\"])(?:(?!\\2).)*(?-i)Master\\.php(?i)\\2(?(-2)\\))\\s*;\\s*\\?>\\s*" & @CRLF & _
" (?:\\s*(?:<!--.*?-->))*" & @CRLF & _
" <master\\s*src=([\\'\\\"])(?<master_url>.+?)\\3\\/>(?<content>[\s\S]*)" & @CRLF & _
" $" & @CRLF & _
" /ix" & @CRLF & _
"PREG2;" & @CRLF & _
"" & @CRLF & _
"$raw = file_get_contents(filter_input(INPUT_SERVER, 'SCRIPT_FILENAME'));" & @CRLF & _
"preg_match($re, $raw, $matches);" & @CRLF & _
"" & @CRLF & _
"$master = file_get_contents($matches["master_url"]);" & @CRLF & _
"$child = $matches["content"];" & @CRLF & _
"" & @CRLF & _
"$child_txt = eval2str($child);" & @CRLF & _
"" & @CRLF & _
"$master_txt = eval2str($master);" & @CRLF & _
"" & @CRLF & _
"$placeholder_xml = new DOMDocument();" & @CRLF & _
"@$placeholder_xml->loadHTML($master_txt, LIBXML_NOWARNING);" & @CRLF & _
"" & @CRLF & _
"$child_xml = new DOMDocument();" & @CRLF & _
"@$child_xml->loadHTML($child_txt, LIBXML_NOWARNING);" & @CRLF & _
"" & @CRLF & _
"$child_elems = $child_xml->getElementsByTagName("content");" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"foreach($child_elems as $c)" & @CRLF & _
"{" & @CRLF & _
" $name = $c->getAttribute("name");" & @CRLF & _
" $child_map[$name] = $placeholder_xml->importNode($c, true);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"$placeholder_elems = $placeholder_xml->getElementsByTagName("placeholder");" & @CRLF & _
"while($placeholder_elems->length > 0)" & @CRLF & _
"{" & @CRLF & _
" $oldnode = $placeholder_elems->item(0);" & @CRLF & _
" $name = $oldnode->getAttribute("name");" & @CRLF & _
" " & @CRLF & _
" if(!isset($child_map[$name]))" & @CRLF & _
" {" & @CRLF & _
" $newnode = $placeholder_xml->createElement("content");" & @CRLF & _
" $attr = $placeholder_xml->createAttribute("name");" & @CRLF & _
" $attr->value = $name;" & @CRLF & _
" $newnode->appendChild($attr);" & @CRLF & _
" $child_map[$name] = $newnode;" & @CRLF & _
" }" & @CRLF & _
" $newnode = $child_map[$name];" & @CRLF & _
" " & @CRLF & _
" $parent = $oldnode->parentNode;" & @CRLF & _
" " & @CRLF & _
" $parent->replaceChild($newnode, $oldnode);" & @CRLF & _
" $placeholder_elems = $placeholder_xml->getElementsByTagName("placeholder"); // " & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"die($placeholder_xml->saveHTML()); // to end execution of the remaining code in the calling file" & @CRLF & _
"/*" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"function eval2str($code)" & @CRLF & _
"{" & @CRLF & _
" ob_start();" & @CRLF & _
" eval("?>$code");" & @CRLF & _
" return ob_get_clean();" & @CRLF & _
"}" & @CRLF & _
"?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")