$re = '/(?<key>\w*) # The key.
\s*:\s* # : with optional spaces around.
(?<value> # The value.
# A string value, single or double-quoted:
(?<quote>["\']) # Capture the double or single quote.
(?:\\\\.|.)*? # Backslash followed by anything or any char, ungreedy.
\k<quote> # The double or single quote captured before.
|
# Int and float numbers:
(?<number>[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?)
|
# true, false and null (or other constants):
(?<constant>true | false | null)
)/x';
$str = '# OK for very simple stuff, such as this:
{
float: \'null\',
another: "foo",
age: 45,
type: \'"simple" \\\' quote\',
comment: "Hello,\\nA backslash \\\\, a tab \\t and a \\"dummy\\" word.\\nOk?",
important: true,
weight: 69.7,
negative: -2.5
}
Not ok for complex stuff:
{
subStaff: {
help: true,
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);